Would be great if we have grid variables in the base framework.
It’s handy having the vars so we can use them using the contextual menu.
I would recommend the utility classes values to change from 1fr 1fr to repeat(2,minmax(0, 1fr)) to avoid a possible overflow.
I see different template devs use different ways to approach this. With the vars I think they all could stick to the same approach that seems it’s the preferred way for the end users.
Naming suggestion –columns to stick to the Core naming or –grid could be okay too.